易语言超级列表框之检查框常用易语言源码

  • A+
所属分类:源码分享

简单的给大家说一下吧。以后肯定也用得到。呵呵。希望能帮助大家!

1:超级列表框之检查框导入默认全选

首先确保超级列表框的属性 有一项      是否有检查框,将它设为真,否则无效!

  1. 超级列表框1.置状态图片 (i - 1, 选择 (超级列表框1.取当前状态图片 (i - 1) = 010))

2:超级列表框之检查框按钮全选

  1. .版本 2
  2. .支持库 iext
  3. .子程序 _按钮_全选_被单击, , , 孤单博客 www.gudanba.com
  4. .局部变量 i, 整数型
  5. .计次循环首 (超级列表框1.取表项数 (), i)
  6.     超级列表框1.置状态图片 (i - 11)
  7. .计次循环尾 ()

3:超级列表框之检查框按钮反选

  1. .版本 2
  2. .支持库 iext
  3. .子程序 _按钮_反选_被单击, , , 孤单博客 www.gudanba.com
  4. .局部变量 i, 整数型
  5. .计次循环首 (超级列表框1.取表项数 (), i)
  6.     超级列表框1.置状态图片 (i - 1, 选择 (超级列表框1.取当前状态图片 (i - 1) = 010))
  7. .计次循环尾 ()

4:超级列表框之检查框按钮删除选中

  1. .版本 2
  2. .支持库 iext
  3. .子程序 _按钮_删除选中_被单击, , , 孤单博客 www.gudanba.com
  4. .局部变量 i, 整数型
  5. .计次循环首 (超级列表框1.取表项数 (), )
  6.     i = i + 1
  7.     .如果真 (超级列表框1.取当前状态图片 (i - 1) = 1)
  8.         超级列表框1.删除表项 (i - 1)
  9.         i = i - 1
  10.     .如果真结束
  11. .计次循环尾 ()
  • 交流群
  • 扫一扫和我一起交流
  • weinxin
  • QQ游戏群
  • 扫一扫和我一起游戏
  • weinxin

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: