易语言超级列表框之检查框常用易语言源码

简单的给大家说一下吧。以后肯定也用得到。呵呵。希望能帮助大家!

1:超级列表框检查框导入默认全选

首先确保超级列表框的属性 有一项      是否有检查框,将它设为真,否则无效!

  1. 超级列表框1.置状态图片 (i - 1, 选择 (超级列表框1.取当前状态图片 (i - 1) = 010))

2:超级列表框之检查框按钮全选

  1. .版本 2
  2. .支持库 iext
  3. .子程序 _按钮_全选_被单击, , , 孤单博客 www.gudanba.com
  4. .局部变量 i, 整数型
  5. .计次循环首 (超级列表框1.取表项数 (), i)
  6.     超级列表框1.置状态图片 (i - 11)
  7. .计次循环尾 ()

3:超级列表框之检查框按钮反选

  1. .版本 2
  2. .支持库 iext
  3. .子程序 _按钮_反选_被单击, , , 孤单博客 www.gudanba.com
  4. .局部变量 i, 整数型
  5. .计次循环首 (超级列表框1.取表项数 (), i)
  6.     超级列表框1.置状态图片 (i - 1, 选择 (超级列表框1.取当前状态图片 (i - 1) = 010))
  7. .计次循环尾 ()

4:超级列表框之检查框按钮删除选中

  1. .版本 2
  2. .支持库 iext
  3. .子程序 _按钮_删除选中_被单击, , , 孤单博客 www.gudanba.com
  4. .局部变量 i, 整数型
  5. .计次循环首 (超级列表框1.取表项数 (), )
  6.     i = i + 1
  7.     .如果真 (超级列表框1.取当前状态图片 (i - 1) = 1)
  8.         超级列表框1.删除表项 (i - 1)
  9.         i = i - 1
  10.     .如果真结束
  11. .计次循环尾 ()
1.本文部分内容转载自其它媒体,但并不代表本站赞同其观点和对其真实性负责。
2.若您需要商业运营或用于其他商业活动,请您购买正版授权并合法使用。
3.如果本站有侵犯、不妥之处的资源,请在网站最下方联系我们。将会第一时间解决!
4.本站所有内容均由互联网收集整理、网友上传,仅供大家参考、学习,不存在任何商业目的与商业用途。
5.本站提供的所有资源仅供参考学习使用,版权归原著所有,禁止下载本站资源参与商业和非法行为,请在24小时之内自行删除!
孤单博客 » 易语言超级列表框之检查框常用易语言源码
  • 50会员总数(位)
  • 287资源总数(个)
  • 1本周发布(个)
  • 0 今日发布(个)
  • 245稳定运行(天)

提供最优质的资源集合

加入海王 加入Q群
开通海王 享更多特权,建议使用 QQ 登录